* use the correct plugin interface version number
[olsrd.git] / lib / quagga / src / olsrd_plugin.c
index fd0c1f9..118e477 100644 (file)
@@ -29,6 +29,8 @@
 #define PLUGIN_VERSION "0.2.2"
 #define PLUGIN_AUTHOR  "Immo 'FaUl' Wehrenberg"
 #define MOD_DESC PLUGIN_NAME " " PLUGIN_VERSION " by " PLUGIN_AUTHOR
+#define PLUGIN_INTERFACE_VERSION 4
+
 
 static void __attribute__ ((constructor)) my_init(void);
 static void __attribute__ ((destructor)) my_fini(void);
@@ -36,7 +38,7 @@ static void redist_hna (void);
 
 
 int olsrd_plugin_interface_version() {
-  return OLSRD_PLUGIN_INTERFACE_VERSION;
+  return PLUGIN_INTERFACE_VERSION;
 }