As agreed upon with Henning some time ago, -Werror should not
authorL. Aaron Kaplan <aaron@lo-res.org>
Sat, 22 Aug 2009 21:36:37 +0000 (23:36 +0200)
committerL. Aaron Kaplan <aaron@lo-res.org>
Sat, 22 Aug 2009 21:36:37 +0000 (23:36 +0200)
commit7270e43a069c6921df317a4abbd8b5b03026529c
treee34e25a2245f9cffe65f469fa0980a798672a89e
parentb9844fc08537cd512565b08cdc70ca9769c21713
As agreed upon with Henning some time ago, -Werror should not
be enabled in the stable branch. Why?
Because the life cycle of -stable is longer and compilers
on many different OSes have to be supported. The compilers
and their warnings might change however. So therefore a now
-Wall -Werror clean build might not be clean some time in the
future without a single line of change inside of olsrd.
So therefore, disable -Werror in the -stable branch.
Makefile.inc