PUD: replace rt.jar file with ee.j2se.jar
authorFerry Huberts <ferry.huberts@pelagic.nl>
Fri, 6 Apr 2012 09:40:46 +0000 (11:40 +0200)
committerFerry Huberts <ferry.huberts@pelagic.nl>
Fri, 6 Apr 2012 09:40:46 +0000 (11:40 +0200)
commitc38b933cd5cb8fb0276d0f55cba76c308d40a0e0
tree5f36f66535fe2fa34684d4d84b00f43608149f7d
parente96080cb821a651f4d4f68c75b31a6f1b47a2214
PUD: replace rt.jar file with ee.j2se.jar

We now use an API-only jar file which is much smaller and
has a more permissive license (APL 2.0) than the OpenJDK
rt.jar file (GPLv2 with classpath exception).

Note that this jar file is only used at build time, it
is _not_ included in any of the binaries. Please refer
to the lib/pud/wireformat-java/README for an explantion.

Signed-off-by: Ferry Huberts <ferry.huberts@pelagic.nl>
lib/pud/wireformat-java/Makefile
lib/pud/wireformat-java/README [new file with mode: 0644]
lib/pud/wireformat-java/resources/How_to_cross-compile_for_older_platform_versions__Joseph_D__Darc.pdf [moved from lib/pud/wireformat-java/resources/jre/How_to_cross-compile_for_older_platform_versions__Joseph_D__Darc.pdf with 100% similarity]
lib/pud/wireformat-java/resources/New_javac_warning_for_setting_an_older_source_without_bootclassp.pdf [moved from lib/pud/wireformat-java/resources/jre/New_javac_warning_for_setting_an_older_source_without_bootclassp.pdf with 100% similarity]
lib/pud/wireformat-java/resources/build.xml
lib/pud/wireformat-java/resources/ee.j2se/1.6/LICENSE [new file with mode: 0644]
lib/pud/wireformat-java/resources/ee.j2se/1.6/ee.j2se.jar [new file with mode: 0644]
lib/pud/wireformat-java/resources/jre/1.6/rt.jar [deleted file]