Another fix for Linux-2.4