pud: fix the build against libgpsd 3.18