android: the pud plugin requires NDK r8, so document this