Fix Linux kernel version check for >= 3.x.x