pud: adjust to new nmealib