pud: use the proper __ANDROID__ define